Rocksolid Light

Welcome to novaBBS (click a section below)

mail  files  register  nodelist  faq  login

"Home, Sweet Home" must surely have been written by a bachelor. -- Samuel Butler


rocksolid / Helpdesk / Re: ctlinnd does not work

SubjectAuthor
* ctlinnd does not workwed
`* Re: ctlinnd does not workwed
 `* Re: ctlinnd does not workRetro Guy
  +* Re: ctlinnd does not workwed
  |`- Re: ctlinnd does not workRetro Guy
  `* Re: ctlinnd does not workRetro Guy
   `- Re: ctlinnd does not workwed

1
Subject: ctlinnd does not work
From: wed
Newsgroups: rocksolid.shared.helpdesk
Organization: Dancing elephants
Date: Fri, 1 Sep 2017 01:11 UTC
From: wed...@retrobbs.synchro.net (wed)
To: rocksolid.shared.helpdesk
Subject: ctlinnd does not work
Message-ID: <oo9jgf$6u3$1@networks.retrobbs.synchro.net>
Date: Fri, 1 Sep 2017 01:11:29 +0000
X-Comment-To: rocksolid.shared.helpdesk
Path: retrobbs.novabbs.com!rocksolid2!retrobbs.synchro.net!networks!.POSTED!not-for-mail
Organization: Dancing elephants
Newsgroups: rocksolid.shared.helpdesk
Reply-To: wed <wed@retrobbs.synchro.net>
X-FTN-PID: Synchronet 3.17a-Linux Jun 15 2017 GCC 4.9.2
Lines: 8
NNTP-Posting-Host: localhost
Mime-Version: 1.0
Content-Type: text/plain; charset=utf-8; format=flowed
Content-Transfer-Encoding: 8bit
X-Trace: networks.retrobbs.synchro.net 1504203090 7107 127.0.0.1 (31 Aug 2017 18:11:30 GMT)
X-Complaints-To: usenet@networks.retrobbs.synchro.net
NNTP-Posting-Date: Thu, 31 Aug 2017 18:11:30 +0000 (UTC)
User-Agent: FUDforum 3.0.7
X-FUDforum: 2dce8cda11477833bf327d9923a5b8d6 <3596>
View all headers
No matter what the parameters, I keep getting:

ctlinnd: cannot setup communication (mkstemp failure): No such file or directory

Seems like something general is not working.
--
-message sent by wed-
Posted by:wed <wed@retrobbs.synchro.net>


Subject: Re: ctlinnd does not work
From: wed
Newsgroups: rocksolid.shared.helpdesk
Organization: Dancing elephants
Date: Fri, 1 Sep 2017 02:37 UTC
References: 1
From: wed...@retrobbs.synchro.net (wed)
To: rocksolid.shared.helpdesk
Subject: Re: ctlinnd does not work
Message-ID: <oo9oht$c7q$1@networks.retrobbs.synchro.net>
Date: Fri, 1 Sep 2017 02:37:36 +0000
X-Comment-To: rocksolid.shared.helpdesk
Path: retrobbs.novabbs.com!rocksolid2!retrobbs.synchro.net!networks!.POSTED!not-for-mail
Organization: Dancing elephants
Newsgroups: rocksolid.shared.helpdesk
Reply-To: wed <wed@retrobbs.synchro.net>
In-Reply-To: <oo9jgf$6u3$1@networks.retrobbs.synchro.net>
References: <oo9jgf$6u3$1@networks.retrobbs.synchro.net>
X-FTN-PID: Synchronet 3.17a-Linux Jun 15 2017 GCC 4.9.2
Lines: 6
NNTP-Posting-Host: localhost
Mime-Version: 1.0
Content-Type: text/plain; charset=utf-8; format=flowed
Content-Transfer-Encoding: 8bit
X-Trace: networks.retrobbs.synchro.net 1504208256 12538 127.0.0.1 (31 Aug 2017 19:37:36 GMT)
X-Complaints-To: usenet@networks.retrobbs.synchro.net
NNTP-Posting-Date: Thu, 31 Aug 2017 19:37:36 +0000 (UTC)
User-Agent: FUDforum 3.0.7
X-FUDforum: 2dce8cda11477833bf327d9923a5b8d6 <3597>
View all headers
Inn2 is a piece of work, there seem to be multiple issues with the installation I did.

Damn. Maybe I will try srnd instead.
--
-message sent by wed-
Posted by:wed <wed@retrobbs.synchro.net>


Subject: Re: ctlinnd does not work
From: Retro Guy
Newsgroups: rocksolid.shared.helpdesk
Organization: RetroBBS
Date: Fri, 1 Sep 2017 04:35 UTC
References: 1
From: retro....@retrobbs.synchro.net (Retro Guy)
To: wed
Subject: Re: ctlinnd does not work
Message-ID: <59A88109.3.rs.helpdesk@retrobbs.synchro.net>
Date: Thu, 31 Aug 2017 21:35:06 -0700
X-Comment-To: wed
Path: retrobbs.novabbs.com!rocksolid2!retrobbs.synchro.net!not-for-mail
Organization: RetroBBS
Newsgroups: rocksolid.shared.helpdesk
In-Reply-To: <oo9oht$c7q$1@networks.retrobbs.synchro.net>
References: <oo9oht$c7q$1@networks.retrobbs.synchro.net>
X-FTN-PID: Synchronet 3.17a-Linux Jun 15 2017 GCC 4.9.2
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101Icedove/45.6.0
MIME-Version: 1.0
Content-Type: text/plain; charset=utf-8; format=flowed
Content-Transfer-Encoding: 7bit
View all headers
On 08/31/2017 12:37 PM, wed wrote:
Inn2 is a piece of work, there seem to be multiple issues with the
installation I did.

Damn. Maybe I will try srnd instead.

That's not good. My inn2 installation went fine and I've had no issues/errors.

I installed as a package. I run debian and used the package manager to install. ctlinnd worked from the start.

Are you maybe having a permissions issue? Did you install from source, or from a distribution's package?

Retro Guy


Subject: Re: ctlinnd does not work
From: wed
Newsgroups: rocksolid.shared.helpdesk
Organization: Dancing elephants
Date: Fri, 1 Sep 2017 12:00 UTC
References: 1
From: wed...@retrobbs.synchro.net (wed)
To: rocksolid.shared.helpdesk
Subject: Re: ctlinnd does not work
Message-ID: <ooapi5$m15$1@networks.retrobbs.synchro.net>
Date: Fri, 1 Sep 2017 12:00:55 +0000
X-Comment-To: rocksolid.shared.helpdesk
Path: retrobbs.novabbs.com!rocksolid2!retrobbs.synchro.net!networks!.POSTED!not-for-mail
Organization: Dancing elephants
Newsgroups: rocksolid.shared.helpdesk
Reply-To: wed <wed@retrobbs.synchro.net>
In-Reply-To: <59A88109.3.rs.helpdesk@retrobbs.synchro.net>
References: <59A88109.3.rs.helpdesk@retrobbs.synchro.net>
X-FTN-PID: Synchronet 3.17a-Linux Jun 15 2017 GCC 4.9.2
Lines: 5
NNTP-Posting-Host: localhost
Mime-Version: 1.0
Content-Type: text/plain; charset=utf-8; format=flowed
Content-Transfer-Encoding: 8bit
X-Trace: networks.retrobbs.synchro.net 1504242055 22565 127.0.0.1 (1 Sep 2017 05:00:55 GMT)
X-Complaints-To: usenet@networks.retrobbs.synchro.net
NNTP-Posting-Date: Fri, 1 Sep 2017 05:00:55 +0000 (UTC)
User-Agent: FUDforum 3.0.7
X-FUDforum: 2dce8cda11477833bf327d9923a5b8d6 <3600>
View all headers
No, same as you, installed with apt-get install inn2.
It might well be a permission issue, although I did not find anything yet.
--
-message sent by wed-
Posted by:wed <wed@retrobbs.synchro.net>


Subject: Re: ctlinnd does not work
From: Retro Guy
Newsgroups: rocksolid.shared.helpdesk
Organization: RetroBBS
Date: Fri, 1 Sep 2017 12:19 UTC
References: 1
From: retro....@retrobbs.synchro.net (Retro Guy)
To: wed
Subject: Re: ctlinnd does not work
Message-ID: <59A8EDFD.5.rs.helpdesk@retrobbs.synchro.net>
Date: Fri, 1 Sep 2017 05:19:58 -0700
X-Comment-To: wed
Path: retrobbs.novabbs.com!rocksolid2!retrobbs.synchro.net!not-for-mail
Organization: RetroBBS
Newsgroups: rocksolid.shared.helpdesk
In-Reply-To: <ooapi5$m15$1@networks.retrobbs.synchro.net>
References: <ooapi5$m15$1@networks.retrobbs.synchro.net>
X-FTN-PID: Synchronet 3.17a-Linux Jun 15 2017 GCC 4.9.2
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101Icedove/45.6.0
MIME-Version: 1.0
Content-Type: text/plain; charset=utf-8; format=flowed
Content-Transfer-Encoding: 7bit
View all headers
On 08/31/2017 10:00 PM, wed wrote:
No, same as you, installed with apt-get install inn2.
It might well be a permission issue, although I did not find anything yet.

I hope it ends up being something simple.

I'm currently working to get two inn2 servers linked. I installed inn2 in a vm earlier today and that's what I'm working on atm.

Retro Guy


Subject: Re: ctlinnd does not work
From: Retro Guy
Newsgroups: rocksolid.shared.helpdesk
Organization: RetroBBS
Date: Fri, 1 Sep 2017 13:15 UTC
References: 1
From: retro....@retrobbs.synchro.net (Retro Guy)
To: Retro Guy
Subject: Re: ctlinnd does not work
Message-ID: <59A8FB15.6.rs.helpdesk@retrobbs.synchro.net>
Date: Fri, 1 Sep 2017 06:15:51 -0700
X-Comment-To: Retro Guy
Path: retrobbs.novabbs.com!rocksolid2!retrobbs.synchro.net!not-for-mail
Organization: RetroBBS
Newsgroups: rocksolid.shared.helpdesk
In-Reply-To: <59A88109.3.rs.helpdesk@retrobbs.synchro.net>
References: <59A88109.3.rs.helpdesk@retrobbs.synchro.net>
X-FTN-PID: Synchronet 3.17a-Linux Jun 15 2017 GCC 4.9.2
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101Icedove/45.6.0
MIME-Version: 1.0
Content-Type: text/plain; charset=utf-8; format=flowed
Content-Transfer-Encoding: 7bit
View all headers
On 08/31/2017 02:35 PM, Retro Guy wrote:
On 08/31/2017 12:37 PM, wed wrote:
Inn2 is a piece of work, there seem to be multiple issues with the
installation I did.

Damn. Maybe I will try srnd instead.

That's not good. My inn2 installation went fine and I've had no
issues/errors.

I installed as a package. I run debian and used the package manager to
install. ctlinnd worked from the start.

Are you maybe having a permissions issue? Did you install from source,
or from a distribution's package?

Retro Guy

I've just duplicated this error. It is a permissions issue. You need to run ctlinnd as root (it should drop to user 'news' as necessary).

If you can get it running, I can send you a very simple config file and you can try to pull some groups from here.

Retro Guy


Subject: Re: ctlinnd does not work
From: wed
Newsgroups: rocksolid.shared.helpdesk
Organization: Dancing elephants
Date: Fri, 1 Sep 2017 19:02 UTC
References: 1
From: wed...@retrobbs.synchro.net (wed)
To: rocksolid.shared.helpdesk
Subject: Re: ctlinnd does not work
Message-ID: <oobi7o$lon$1@networks.retrobbs.synchro.net>
Date: Fri, 1 Sep 2017 19:02:02 +0000
X-Comment-To: rocksolid.shared.helpdesk
Path: retrobbs.novabbs.com!rocksolid2!retrobbs.synchro.net!networks!.POSTED!not-for-mail
Organization: Dancing elephants
Newsgroups: rocksolid.shared.helpdesk
Reply-To: wed <wed@retrobbs.synchro.net>
In-Reply-To: <59A8FB15.6.rs.helpdesk@retrobbs.synchro.net>
References: <59A8FB15.6.rs.helpdesk@retrobbs.synchro.net>
X-FTN-PID: Synchronet 3.17a-Linux Jun 15 2017 GCC 4.9.2
Lines: 6
NNTP-Posting-Host: localhost
Mime-Version: 1.0
Content-Type: text/plain; charset=utf-8; format=flowed
Content-Transfer-Encoding: 8bit
X-Trace: networks.retrobbs.synchro.net 1504267322 22295 127.0.0.1 (1 Sep 2017 12:02:02 GMT)
X-Complaints-To: usenet@networks.retrobbs.synchro.net
NNTP-Posting-Date: Fri, 1 Sep 2017 12:02:02 +0000 (UTC)
User-Agent: FUDforum 3.0.7
X-FUDforum: 2dce8cda11477833bf327d9923a5b8d6 <3609>
View all headers
I have done that with root already, so thats not it.

There are some things that can cause this error message, and I checked and tried four or five of them that I found in linux forums. But I was unable to improve the situation or to find addtional info. I look into alternative software right now.
--
-message sent by wed-
Posted by:wed <wed@retrobbs.synchro.net>


1
rocksolid light 0.7.2
clearneti2ptor