Rocksolid Light

Welcome to Rocksolid Light

register   nodelist   faq  


rocksolid / rocksolid.nodes.announce / Re: Poetry group not working?

SubjectAuthor
* Poetry group not working?Zod
`* Re: Poetry group not working?Retro Guy
 `* Re: Poetry group not working?Retro Guy
  `- Re: Poetry group not working?Retro Guy

Subject: Poetry group not working?
From: Zod@rslight.i2p (Zod)
Newsgroups: rocksolid.nodes.announce
Organization: Rocksolid Light
Date: Sun, 7 Jun 2020 07:36 UTC
The poetry group seems to not be working:

https://www.novabbs.com/arts/thread.php?group=alt.arts.poetry.comments


--
Posted on: Rocksolid Light
www.novabbs.com


Subject: Re: Poetry group not working?
From: Retro Guy@rslight.i2p (Retro Guy)
Newsgroups: rocksolid.nodes.announce
Organization: Rocksolid Light
Date: Sun, 7 Jun 2020 10:51 UTC
Zod wrote:

The poetry group seems to not be working:

https://www.novabbs.com/arts/thread.php?group=alt.arts.poetry.comments

Yes, sorry about that. This is development software, and I made a change that caused the issue. Any posts you made during that time should have gone out a few minutes ago.

I hopefully have fixed the problem. I will be back tomorrow and check on it. I have time after working tomorrow to devote effort into any issues that may show up.

Thanks for reporting the issue!

Retro Guy

--
Posted on: Rocksolid Light
www.novabbs.com



Subject: Re: Poetry group not working?
From: Retro Guy@rslight.i2p (Retro Guy)
Newsgroups: rocksolid.nodes.announce
Organization: Rocksolid Light
Date: Sun, 7 Jun 2020 11:04 UTC
I actually didn't notice the issue for a while because I got confused between UTC and my local time. Everything looked good in the logs as I was only looking at the minutes, not hours. That'll learn me!

Retro Guy


--
Posted on: Rocksolid Light
www.novabbs.com



Subject: Re: Poetry group not working?
From: Retro Guy@rslight.i2p (Retro Guy)
Newsgroups: rocksolid.nodes.announce
Organization: Rocksolid Light
Date: Sun, 7 Jun 2020 11:37 UTC
For anyone interested in the technical reason for the problem, here it is:

I use lock files for scripts so some processes don't step on each other. For example, I don't want to start pulling articles for a group if I'm still pulling articles for that group as that would mess up the watermark file.

So I used the same lockfile name for locally posting articles as pulling articles, but the process id set in that lockfile ended up being the PID of the nntp server. I uploaded to the server the change, and ran it. It all worked well until someone posted, then it got stuck as the PID of the nntp server continued running and no posts would go out.

Fortunately, posts are held for sending, so once I saw the problem and fixed it, the posts all went out and were not lost.

I'll check back tomorrow to hopefully see it is still working fine. If not, I'm off work Monday and should be able to resolve any issue.

Retro Guy

--
Posted on: Rocksolid Light
news.novabbs.com



1
rocksolid light 0.6.5e
clearnet i2p tor