Rocksolid Light

Welcome to Rocksolid Light

register   nodelist   faq  


rocksolid / rocksolid.nodes.announce / Re: charset in subjects

SubjectAuthor
* rslight-0.6.5dRetro Guy
+* Re: rslight-0.6.5dRetro Guy
|`* Re: rslight-0.6.5dAnonUser
| `* Re: rslight-0.6.5dRetro Guy
|  `* Re: rslight-0.6.5dRetro Guy
|   `- Re: rslight-0.6.5dRetro Guy
+- this is your favorite guineapig againAnonymous
+- of, the threads are intact nowAnonymous
+* i have a feature request for rslightAnonymous
|`- Re: i have a feature request for rslightRetro Guy
+* i was too optimisticAnonymous
|`- Re: i was too optimisticRetro Guy
+* also missing indecesAnonymous
|`- Re: also missing indecesRetro Guy
+- status report :-)Anonymous
+- several newsserversAnonymous
+* NoneAnonymous
|`- Re: Noneanonymous
+* still problemsAnonymous
|`* Re: still problemsRetro Guy
| +- Re: still problemsRetro Guy
| `* Re: still problemsanonymous
|  `* Re: still problemsRetro Guy
|   `* Re: still problemsanon
|    +- Re: still problemsRetro Guy
|    `* Re: still problemsRetro Guy
|     `- Re: still problemsanonymous
+- message can be accessed nowAnonymous
+- i don't get itAnonymous
+- still not working, reallyAnonymous
+* charset in subjectsAnonymous
|`- Re: charset in subjectsRetro Guy
+- this was vichanAnonymous
+* first sync after changeAnonymous
|`* Re: first sync after changeRetro Guy
| `* Re: first sync after changeRetro Guy
|  `* Re: first sync after changeRetro Guy
|   `- Re: first sync after changeRetro Guy
+- deleted the spool filesAnonymous
+* that fixed social as wellAnonymous
|`- Re: that fixed social as wellRetro Guy
+- Re: rslight-0.6.5danon
+* the new function works at leastAnonymous
|`* Re: the new function works at leastRetro Guy
| `* Re: the new function works at leastanon
|  `- Re: the new function works at leastRetro Guy
+- so far so goodAnonymous
+* but the message is thereAnonymous
|`- Re: but the message is thereRetro Guy
+* okAnonymous
|`* Re: okRetro Guy
| `* Re: okRetro Guy
|  `* Re: okRetro Guy
|   `* Re: okRetro Guy
|    `* Re: okRetro Guy
|     `* Re: okRetro Guy
|      `* Re: okRetro Guy
|       `* Re: okRetro Guy
|        `- Re: okRetro Guy
+* watermarksAnonymous
|`- Re: watermarksRetro Guy
+* the new spoolnews.phpAnonymous
|`- Re: the new spoolnews.phpRetro Guy
+- seems to be workingAnonymous
+* now can you explain why the bugsAnonymous
|`- Re: now can you explain why the bugsRetro Guy
`- this fixed quite a lotAnonymous

Subject: i don't get it
From: poster@anon.com (Anonymous)
Newsgroups: rocksolid.nodes.announce
Organization: i2pn2 (i2pn.org)
Date: Thu, 28 May 2020 15:51 UTC
the articles are in the spool, but rslight just does not show them.


Subject: Re: still problems
From: Retro Guy@example.com (Retro Guy)
Newsgroups: rocksolid.nodes.announce
Organization: rslight Debian test site
Date: Fri, 29 May 2020 06:59 UTC
Anonymous wrote:

main index is working now, but programming and social are still out of it.
also a problem to access some other messages (like http://z5bqfv5v75kxy7pj.onion/rocksolid/article-flat.php?id=104&group=rocksolid.nodes.announce#104 ).

I believe I have duplicated the problem on a test site. This test site also connects to it's upstream server via i2p.

I'll be working on it on this site trying to determine what's causing the problem, but currently r.s.programming is also broken on the test site. This is a good thing, it allows me to see the problem in action locally.

I'll get back with info once I do some troubleshooting, but it may take a couple of days.

Retro Guy

--
Posted on: rslight Debian test site
192.168.0.220



Subject: Re: still problems
From: Retro Guy@rslight.i2p (Retro Guy)
Newsgroups: rocksolid.nodes.announce
Organization: Rocksolid Light
Date: Fri, 29 May 2020 07:52 UTC
Retro Guy wrote:

Anonymous wrote:

main index is working now, but programming and social are still out of it.
also a problem to access some other messages (like http://z5bqfv5v75kxy7pj.onion/rocksolid/article-flat.php?id=104&group=rocksolid.nodes.announce#104 ).

I believe I have duplicated the problem on a test site. This test site also connects to it's upstream server via i2p.

I'll be working on it on this site trying to determine what's causing the problem, but currently r.s.programming is also broken on the test site. This is a good thing, it allows me to see the problem in action locally.

I'll get back with info once I do some troubleshooting, but it may take a couple of days.

I'm currently rebuilding the spool with a modified spoolnews.php that will break out of the download loop and unlink the local file if connection is lost to upstream server. I've also added a log entry if this happens.

I'll continue testing to see if this is hopefully the problem.

Retro Guy

--
Posted on: Rocksolid Light
www.novabbs.com



Subject: still not working, really
From: poster@anon.com (Anonymous)
Newsgroups: rocksolid.nodes.announce
Organization: i2pn2 (i2pn.org)
Date: Fri, 29 May 2020 12:52 UTC
articles from social and programming cannot be found.
think i will just for debugging purposes hook the nntp server of def2 to my own.


Subject: charset in subjects
From: poster@anon.com (Anonymous)
Newsgroups: rocksolid.nodes.announce
Organization: i2pn2 (i2pn.org)
Date: Fri, 29 May 2020 14:08 UTC
i just had to change one article manually, because the character ² (square) was included.
this is the error message from spoolnews:

May 29 14:05:26 rocksolid Failed to POST: a8c8ed: 441 Invalid syntax encountered in Subject: header field body (unexpected byte or empty content line)
 
do yo know if that is part of the spec for news ? or is it something specific to rslight ?

cheers


trw


Subject: Re: charset in subjects
From: Retro Guy@rslight.i2p (Retro Guy)
Newsgroups: rocksolid.nodes.announce
Organization: Rocksolid Light
Date: Fri, 29 May 2020 23:02 UTC
Anonymous wrote:

i just had to change one article manually, because the character ² (square) was included. this is the error message from spoolnews:

May 29 14:05:26 rocksolid Failed to POST: a8c8ed: 441 Invalid syntax encountered in Subject: header field body (unexpected byte or empty content line)

do yo know if that is part of the spec for news ? or is it something specific to rslight ?

rslight will mime encode headers when necessary, so it shouldn't send such a messaage. Is this a message from vichan? That error message is from an inn server and spoolnews is just logging it.


--
Posted on: Rocksolid Light
www.novabbs.com



Subject: this was vichan
From: poster@anon.com (Anonymous)
Newsgroups: rocksolid.nodes.announce
Organization: i2pn2 (i2pn.org)
Date: Sat, 30 May 2020 12:16 UTC
rslight will mime encode headers when necessary, so it shouldn't send such a messaage.

it doesn't.

Is this a message from vichan? That error message is from an inn server and spoolnews is just logging it.

I thought the error might be from the rslight news server.

One more point on the vichan todo list.


Subject: Re: still problems
From: anonymous@anon.com (anonymous)
Newsgroups: rocksolid.nodes.announce
Organization: def2
Date: Sat, 30 May 2020 16:23 UTC
This is a good thing, it allows me to see the problem in action locally.

I saw this one too late, but yes, this is very good.
From your post before I understand that the problem might be in incomplete messsages...
and just I see that you probably rebuild your spool (at least spoolnews reports a lot of duplicates).

cheers

trw
--
Posted on def2
z5bqfv5v75kxy7pj.onion


Subject: Re: still problems
From: Retro Guy@example.com (Retro Guy)
Newsgroups: rocksolid.nodes.announce
Organization: rslight Debian test site
Date: Sat, 30 May 2020 23:32 UTC
anonymous wrote:

This is a good thing, it allows me to see the problem in action locally.

I saw this one too late, but yes, this is very good.
From your post before I understand that the problem might be in incomplete messsages...
and just I see that you probably rebuild your spool (at least spoolnews reports a lot of duplicates).

You're seeing that on def2 logs? I'm pretty sure def2 is connecting to one of my inn2 servers as it's upstream server (i2pn2), not to an rslight server. I haven't changed anything on i2pn2, or any of my spools. Only on a test site right now have I done that.

The duplicate message log entry is harmless. It usually happens when/if you lose your connection to upstream and on next run it starts at the low number again. Using the opportunity to post from the test site now also.

Retro Guy

--
Posted on: rslight Debian test site
192.168.0.220


Subject: Re: still problems
From: anon@anon.com (anon)
Newsgroups: rocksolid.nodes.announce
Organization: def5
Date: Sun, 31 May 2020 01:01 UTC

You're seeing that on def2 logs?
Yes, and a lot of messages from many groups. That is why I was assuming the spool numbers had changed on your server (which I remember they do from time to time, right ?).

I'm pretty sure def2 is connecting to one of my inn2 servers as it's upstream server (i2pn2), not to an rslight server.

Yes, that is true of course. So it can't have anything to do with your experiments.

The duplicate message log entry is harmless.

That's what I thought. It was just the sheer number of logs entries in a row (I follow that log with tail -f) that made me look twice.

It usually happens when/if you lose your connection to upstream

These connection problems can happen over i2p easily of course. Maybe it would be better if I would connect to my own inn instead ?

If you want I could also try the new spoolnews code, would be interesting to see.

cheers

trw

and on next run it starts at the low number again. Using the opportunity to post from the test site now also.

Posted on def4


Pages:1234567
rocksolid light 0.6.5e
clearnet i2p tor